package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<host>[^\/:]+)[\/:](?<port>[^\/:]+)\/(?<path>.+\/)?(?<repo>.+?)(?<suffix>\.git[\/]?)?$`)
var str = `ssh://git@gitlab.sickcn.net:10022/Platforms/euler/components/appengine/flow_engine.git/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}