using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\.\d*?[1-9]+)|\.)0*$";
string substitution = @"$1";
string input = @"21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}