package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\.\d*?[1-9]+)|\.)0*$`)
var str = `21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}