#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$"
Local $sString = "5" & @CRLF & _
"foster" & @CRLF & _
"foster steve" & @CRLF & _
"foster-morrison" & @CRLF & _
"hello" & @CRLF & _
"*RKER(($(#$)#$#L$KLK#$*" & @CRLF & _
"dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd" & @CRLF & _
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg" & @CRLF & _
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd" & @CRLF & _
"dkfkerksf------aaa-----" & @CRLF & _
"test---me" & @CRLF & _
"foster-mo" & @CRLF & _
"f-morrison" & @CRLF & _
"griffith-joiner" & @CRLF & _
"test-" & @CRLF & _
"-dkd" & @CRLF & _
"d'andre" & @CRLF & _
"d'andre-jordan" & @CRLF & _
"jordan-d'andre" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")