// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$").unwrap();
let string = "5
foster
foster steve
foster-morrison
hello
*RKER(($(#$)#$#L$KLK#$*
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
dkfkerksf------aaa-----
test---me
foster-mo
f-morrison
griffith-joiner
test-
-dkd
d'andre
d'andre-jordan
jordan-d'andre
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}