import Foundation
let pattern = #"^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
5
foster
foster steve
foster-morrison
hello
*RKER(($(#$)#$#L$KLK#$*
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
dkfkerksf------aaa-----
test---me
foster-mo
f-morrison
griffith-joiner
test-
-dkd
d'andre
d'andre-jordan
jordan-d'andre
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)