re = /^(\d{10}|\d{12})$/m
str = '1234567890
123456789012
12345678901
123456
1234567890123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end