package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-.]+@(?:[\w-]+\.)+[a-z]{2,6}$`)
var str = `123-.@qq.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}