Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[\w-.]+@(?:[\w-]+\.)+[a-z]{2,6}$
/
gm
Input 1
1
New
123-.@qq.com