using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^4[0-9]{12}(?:[0-9]{3})?$";
string input = @"4231200000951458";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}