import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\.[^(\\s|\\.)].*$";
final String string = ".Caution vs. Warning\n"
+ "[#caution-vs-warning]\n\n"
+ ". ghfghgh\n"
+ ".. ghghghgf\n\n\n"
+ ".Admonition paragraph syntax\n"
+ "[source]\n"
+ "----\n"
+ "WARNING: Wolpertingers are known to nest in server racks. <1> <2>\n"
+ "Enter at your own risk.\n"
+ "----\n"
+ "<1> The label must be uppercase and immediately followed by a colon (`:`).\n"
+ "<2> Separate the first line of the paragraph from the label by a single space.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}