using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^node:.*";
string input = @"/path/to/a.txt
node:path
node:path
node:https
node:http
node:zlib
/path/to/b.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}