$re = '/^node:.*/m';
$str = '/path/to/a.txt
node:path
node:path
node:https
node:http
node:zlib
/path/to/b.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);