$re = '/^(?=.*[a-zA-Z])([a-zA-Z\d]+)$/m';
$str = 'This is success scenario:
123456a
123a456
1aaaaaa
abacefj
1a45s4d
This is wrong scenaio:
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);