# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:.+|)\b(fees|fee|charge|charges)\b(?:.+|)$"
test_str = ("Anything else you wish fees credit card\n"
"Anything else you wish fee credit card\n"
"charges for interest\n"
"charge for interest\n"
"charger for device\n"
"coffee shop\n"
"feeder cattle")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.