import Foundation
let pattern = #"(?:.+|)\b(fees|fee|charge|charges)\b(?:.+|)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Anything else you wish fees credit card
Anything else you wish fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)