import Foundation
let pattern = #"(?!^id|id{1,})(?<=id|^).+?(?=id|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)