# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m-s)^(..).*+(?>\r?\n\1.*){2}\K(?:\r?\n\1.*)+//g;t' <<< "at58
at59
at60
at61
at62
au344
au347
au348
au349
au350
ba5
ba6
ba7
be72
be73
be74
be75
be76 "