const regex = /(?m-s)^(..).*+(?>\r?\n\1.*){2}\K(?:\r?\n\1.*)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m-s)^(..).*+(?>\\r?\\n\\1.*){2}\\K(?:\\r?\\n\\1.*)+', 'g')
const str = `at58
at59
at60
at61
at62
au344
au347
au348
au349
au350
ba5
ba6
ba7
be72
be73
be74
be75
be76 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);