use strict;
my $str = 'at58
at59
at60
at61
at62
au344
au347
au348
au349
au350
ba5
ba6
ba7
be72
be73
be74
be75
be76 ';
my $regex = qr/(?m-s)^(..).*+(?>\r?\n\1.*){2}\K(?:\r?\n\1.*)+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";