# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<TopicSet.*?>)([\s\S]*?)(<\\/TopicSet>)/$1$2$3/mg;t' <<< "<TopicSet FormalName=\"PARENT1\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>
<TopicSet FormalName=\"PARENT2\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>"