#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*\{\/\*DELETE}(\s*(?:\r?\n(?!\s*\{(?:\/\*DELETE|DELETE\*\/)}).*)*)\r?\n\s*\{DELETE\*\/}\s*$"
Local $sString = "Keep1" & @CRLF & _
"{/*DELETE}" & @CRLF & _
"Delete1a" & @CRLF & _
" {/*DELETE}" & @CRLF & _
" Delete2" & @CRLF & _
" {DELETE*/}" & @CRLF & _
"Delete1b" & @CRLF & _
"{DELETE*/}" & @CRLF & _
"Keep2" & @CRLF & _
"{/*DELETE}" & @CRLF & _
"Delete3" & @CRLF & _
"{DELETE*/}" & @CRLF & _
"Keep3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)