using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(\s+)?([a-z\s]+?)(\s+)?""";
string substitution = @"$2";
string input = @"""name"",""john"",""name of john""
""name"","" john"",""name of john""
"" name "","" john"",""name of john ""
"" name "","" john"","" name of john """;
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}