// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^(https?[^\s?]+\?)
([^\s=]+=[^\s&]+)
(?:\&([^\s=]+=[^\s&]+))?
(?:\&([^\s=]+=[^\s&]+))?
(?:\&([^\s=]+=[^\s&]+))?
").unwrap();
let string = "https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
";
let substitution = " \\1\\2&\\3&\\4&\\5&o=desc&s=updated";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}