# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?[^\s?]+\?)([^\s=]+=[^\s&]+)(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?(?:\&([^\s=]+=[^\s&]+))?"
test_str = ("https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults\n"
" https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated\n")
subst = " \\1\\2&\\3&\\4&\\5&o=desc&s=updated"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.