# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?[^\s?]+\?\S+)/$1&o=desc&s=updated/g;t' <<< "https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
"