#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(https?[^\s?]+\?\S+)"
Local $sString = "https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults" & @CRLF & _
"https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated" & @CRLF & _
""
Local $sSubst = "$1&o=desc&s=updated"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)