use strict;
my $str = 'https://github.com/search?utf8=%E2%9C%93&q=regex%20play&type=Repositories&ref=searchresults
https://github.com/search?utf8=%E2%9C%93&q=regex+play&type=Repositories&ref=searchresults&o=desc&s=updated
';
my $regex = qr/(https?[^\s?]+\?\S+)/p;
my $subst = '$1&o=desc&s=updated';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";