using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z].*?\w[.?!](?<!\ba\.m\.)(?!\S)";
string input = @"At 9:00 a.m. the store opens.
At 9:00 p.m. the store opens.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}