$re = '/[A-Z].*?\w[.?!](?<!\ba\.m\.)(?!\S)/m';
$str = 'At 9:00 a.m. the store opens.
At 9:00 p.m. the store opens.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);