Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((--\S+=\S+|--\S+)(?=\s+|\S+|$))
/
gm
Input 1
1
New
--flag --k1=v1 --k2=v2 -k3=v3 --k4=v4