const regex = new RegExp('\\s*(\\b(?:AND|OR|NOT)\\b|[()])\\s*', 'gm')
const str = `Frank and Bob are nice AND NOT (Henry is good OR Sam is 102 years old)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}