using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*itemprop=""(name|acceptedAnswer|suggestedAnswer)"".*";
string input = @"<div itemscope itemtype=""http://schema.org/Question"">
<h1 itemprop=""name"">Какое геометрическое тело получается вращением круга вокруг своего диаметра?</h1>
<h2>Варианты ответа:</h2>
<div class=""variants"">
<div itemprop=""acceptedAnswer"" itemscope itemtype=""http://schema.org/Answer"" class=""one-fourth correct""><span itemprop=""text"">шар</span></div>
<div itemprop=""suggestedAnswer"" itemscope itemtype=""http://schema.org/Answer"" class=""one-fourth""><span itemprop=""text"">цилиндр</span></div>
<div itemprop=""suggestedAnswer"" itemscope itemtype=""http://schema.org/Answer"" class=""one-fourth""><span itemprop=""text"">конус</span></div>
<div itemprop=""suggestedAnswer"" itemscope itemtype=""http://schema.org/Answer"" class=""one-fourth""><span itemprop=""text"">пирамида</span></div>
</div>
</div>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}