import Foundation
let pattern = #".*itemprop="(name|acceptedAnswer|suggestedAnswer)".*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div itemscope itemtype="http://schema.org/Question">
<h1 itemprop="name">Какое геометрическое тело получается вращением круга вокруг своего диаметра?</h1>
<h2>Варианты ответа:</h2>
<div class="variants">
<div itemprop="acceptedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth correct"><span itemprop="text">шар</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">цилиндр</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">конус</span></div>
<div itemprop="suggestedAnswer" itemscope itemtype="http://schema.org/Answer" class="one-fourth"><span itemprop="text">пирамида</span></div>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)