# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(-[0-9a-f]{32})//g;t' <<< "iPhone6Plus-learn_multi_child-0dfb2dc71fe20da66ca47190d3136b12.png"