package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<marked>\w+$)`)
var str = `A file has been marked as Removed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}