re = /^(?=.*param1=([^&]+)|)(?=.*param2=([^&]+)|)(?=.*param3=([^&]+)|).+$/m
str = '?param1=test1¶m2=test2¶m3=test3
?param1=test1
?param2=test2¶m1=test1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end