using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([a-z])?([a-z])?([a-z])?\2\1\b";
string input = @"words that are the same backwards as forwards
e.g:
kayak, dewed, refer, hanah, but not hannah or henah or ana, nor wow or racecar.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}