#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<img|(?<!^)\G)\h*([-\w]+)="([^"]+)"(?=.*?\/>)"
Local $sString = "<p>List of sample images.</p>" & @CRLF & _
"<img src="https://placehold.it/250x100.jpg" width="250" height="100" alt="Dimensions Set" />" & @CRLF & _
"<img src="https://placehold.it/250x100/99cc00/000.jpg?text=JPG" alt="JPG" /><br>" & @CRLF & _
"<img src="https://placehold.it/250x100.gif?text=GIF" alt="GIF" /><br>" & @CRLF & _
"<img src="https://placehold.it/250x100/ff6600/000.png?text=PNG" alt="PNG" /><br>" & @CRLF & _
"<img class="no-ext" src="https://placehold.it/350x150?text=No Extension" alt="No Ext" /><br>" & @CRLF & _
"<img src="https://placehold.it/250x100.png" custom-attr="custom1" another-attr="custom2" /><br>" & @CRLF & _
"<img class="svg" src="https://upload.wikimedia.org/wikipedia/commons/0/02/SVG_logo.svg" alt="SVG" /><br>" & @CRLF & _
"<img class="webp" src="https://gstatic.com/webp/gallery/1.webp" width="100" alt="webP" /><br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")