import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([aeiouy])(\\s*)([bcdfghjklmnpqrstvwxz])";
final String string = "hello world\n"
+ "xaabeuekadii\n"
+ "A quick brown fox jumps over the lazy dog";
final String subst = "$1$2\\U$3\\E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}