use strict;
my $str = 'hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog';
my $regex = qr/([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])/mip;
my $subst = '$1$2\\U$3\\E';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";