import Foundation
let pattern = #"(?ms)Value\s+0:\s+(?<value0>[^ ]+)Value"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mon Mar 9 14:18:14 2020: Unknown trap (.1.1.1.1.1..1) received from hostname.abcd.com at:
Value 0: hostname.abcd.com
Value 1: 1.2.3.4
Value 2: 11.22.33.44
Another sample value is
Mon Mar 9 13:38:23 2020: Unknown trap (.1.2.3.4.5.6) received from 19.19.19.19 at:
Value 0: 19.19.19.19
Value 1: 4.4.4.4.4
Value 2: 12.13.14.15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)