$re = '/;(?=(?:[^\[\]]*\[[^\[\]]*\])*[^\[\]]*$)
#;|\[|\]/x';
$str = '#first split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX];gene2[position1:oldAA-newAA];gene3[v];gene4;gene5
#second split:
gene1[position1:oldAA-newAA;position2:oldAA-newAA;position3:oldXX-newXX]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;