#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[ ]*([+-]?[ ]*(([1-9][0-9]*)[ ]*(\\*[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)?)|([ ]*[-+]?[ ]*x[ ]*(\\^[ ]*([-+]?[1-9][0-9]*))?)[ ]*)"
Local $sString = "判断多项式是不是合法" & @CRLF & _
"题目文档:" & @CRLF & _
"https://images.ptausercontent.com/2746fa4c-db55-4a55-beb9-459cea89b99d.pdf" & @CRLF & _
"" & @CRLF & _
"1-2*x^-2+5*x^12-4*x+12" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")