import Foundation
let pattern = #"^(\d+),([^,]+),([^,]+),([^,]+),([^,]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1900,Humbert Ier,Gottlieb Daimler,Friedrich Nietzsche,Oscar Wilde"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,$2,$1,$3,$1,$4,$1,$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)