#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+(\[-|\{\+).*$"
Local $sString = "@@ -11 +11 @@ delta dAddressBook {" & @CRLF & _
" private String [-addressA;-]{+address;+}" & @CRLF & _
"@@ -13 +13 @@ delta dAddressBook {" & @CRLF & _
" public [-AddressBookEntryB()-]{+AddressBookEntry()+} {" & @CRLF & _
"@@ -39,0 +40,4 @@ delta dAddressBook {" & @CRLF & _
"" & @CRLF & _
" {+public void setAddress(String address) {+}" & @CRLF & _
"{+ this.address = address;+}" & @CRLF & _
"{+ }+}" & @CRLF & _
"@@ -45,2 +48,0 @@ delta dAddressBook {" & @CRLF & _
"[- import br.unb.cic.iris.core.exception.EmailException;-]" & @CRLF & _
"[- import br.unb.cic.iris.core.model.AddressBookEntry;-]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")