import Foundation
let pattern = #".+(\[-|\{\+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@@ -11 +11 @@ delta dAddressBook {
private String [-addressA;-]{+address;+}
@@ -13 +13 @@ delta dAddressBook {
public [-AddressBookEntryB()-]{+AddressBookEntry()+} {
@@ -39,0 +40,4 @@ delta dAddressBook {
{+public void setAddress(String address) {+}
{+ this.address = address;+}
{+ }+}
@@ -45,2 +48,0 @@ delta dAddressBook {
[- import br.unb.cic.iris.core.exception.EmailException;-]
[- import br.unb.cic.iris.core.model.AddressBookEntry;-]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)