use strict;
my $str = '.net, asp.net hello. world, c#';
my $regex = qr~(?![/#$]|\.(?!\s))\p{P}~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";