// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)*((#\d+)|((box|bin)[-. \/\\]?\d+)|(.*p[ \.]? ?(o|0)[-. \/\\]? *-?((box|bin)|b|(num)?\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+)|(p *-?\/?(o)? *-?box)|post office box|((box|bin)|b) *(number|num)? *\d+|(num|number) *\d+)\d").unwrap();
let string = "PO Box 234, Suburb, ACT, Australia, 5678
123 Some Street
PO BOX 234 Suburb, ACT, Australia, 2342
po box 345, somehwere, state, country, postcode
post office box 2343, nothing ,no state, country , 345
345 smith st, po box 345, no place, no country, 3454
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}