// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[[:alpha:]]+\_[[:alpha:]]+\((([[:digit:]]{1}),([[:digit:]]{4}),([[:digit:]]+)?)\)$").unwrap();
let string = "UW_CF(1,2018,1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}